跳到主要内容

嵌入SDK到Flutter

什么是 Flutter?

Flutter是谷歌的 UI 工具包,用于从单一代码库为移动、网络、桌面和嵌入式设备构建漂亮的、原生编译的应用程序。

XR-MOD 与 Flutter

过去,要在 Flutter 中使用 AR-MOD sdk,开发者需要为 Flutter 项目创建 AR-MOD 插件,这样 Flutter 才能使用 AR-MOD! 我们也发现了这个问题,所以我们在 0.0.4 版本中推出了一个完全支持 Flutter 的插件。我们把它推送到 pub.dev,名字是flutter_armod_widget。 从现在开始,我将带领大家看看如何在 Flutter 中使用 AR-MOD SDK。

警告

我们将跳过如何安装 flutter 以及如何用 flutter 创建一个项目

设置 Flutter 项目

第 1 步

打开pubspec.yaml文件,将flutter_armod_widget: ^2.0.0-pre.1到依赖项。

dependencies:
flutter:
sdk: flutter
flutter_armod_widget: ^2.0.0-pre.1

第二步

在你的项目术语中运行flutter pub get命令,以安装依赖性。

第三步

github下载并解压 AR-MOD SDK 框架。

进入FLUTTER-SDK-PATH/.pub-cache/hosted/pub.dartlang.org/flutter_armod_widget-VERSION/文件夹的位置。 然后将libs粘贴到android平台文件夹。

第四步

  • 再次在你的终端中运行Flutter pub get命令。
  • 创建并写入你的应用程序令牌到PhantomsXRConfig.dart
  • 并为 AR-MOD 写一个新的屏幕。

Build and Test

提示

不需要额外的配置

OK,你只需要在终端运行flutter run --release命令。一个 AR 应用就会在你的手机中运行! 点击这里下载这个源代码!